Taller de “Seguridad en WordPress” en Congreso Web

El próximo viernes 2 de junio de 16:10 a 18:10 en la “Sala WordPress” estaré dando un taller sobre seguridad en WordPress en el Congreso Web (CW17).

Seguridad en WordPress, CW17Según tengo entendido este congreso está orientado principalmente a profesionales del marketing, por lo que doy por hecho que el nivel técnico de los asistentes no es muy alto, así que el taller irá orientado a dicho perfil de usuario, tratando que la gente que no tiene grandes conocimientos técnicos sea capaz de entender la importancia de la seguridad en WordPress y como sentar las bases para tener un WordPress protegido ante los ataques más habituales.

En el taller abarcaremos los siguientes puntos:

  • Análisis inicial de posibles vulnerabilidades.
  • Medidas preventivas para proteger nuestro WordPress.
  • Desinfección de WordPress (cuando ya es tarde para aplicar lo anterior).

Siempre que sea posible trataremos de ver las cosas desde dos enfoques distintos, el de “ensuciarnos” las manos haciendo cambios nosotros mismos, y el de optar por la vía más cómoda de usar un plugin o un servicio de terceros.

En cualquier caso el grueso del taller serán las medidas preventivas, por aquello de más vale prevenir que curar… ;)

Si llevas idea de asistir al taller y quieres poner en práctica lo que se va a tratar en el mismo sobre la marcha, necesitarás lo siguiente:

  • Ordenador portátil (obviamente).
  • Una instalación de WordPress sobre la que aplicar lo que vayamos viendo en el taller. No es necesario que tenga ninguna característica en especial, únicamente si vas a trabajar sobre una web que usas habitualmente es recomendable que te hagas una copia de seguridad de archivos y base de datos antes de empezar el taller.
  • Un cliente de FTP, ya sea FileZilla, WinSCP o cualquier otro que tengas instalado en tu equipo.
  • Un editor de código fuente. No es estrictamente necesario, podría valer cualquier editor de texto, pero es muy recomendable usar un editor de código. El que más te guste, yo usaré Visual Studio Code o Atom. Ambos son gratuitos y multiplataforma.
  • Si quieres practicar el escaneo de vulnerabilidades, y usas Windows, tendrás que instalar el subsistema Linux, en este artículo explican como hacerlo, es mucho más sencillo de lo que parece. Si usas Linux perfecto, y si usas MacOS en teoría tampoco necesitas nada especial. No obstante mi equipo corre sobre Windows 10 y las instrucciones las daré sobre esta base.

Ojo, todo esto es opcional, puedes asistir con las manos en los bolsillos si sólo quieres quedarte con las ideas para aplicarlas en otro momento.

Deja un comentario

Tu dirección de email no será publicada. Campos obligatorios marcados con *